x PhoneArena is hiring! Reviewer in the USA
Samsung GALAXY mini Discussions
  • Options


hey (unregistered) 26 Apr 2011, 01:51 posted on

hey guy, can any one tell me how 2 tirn on 3G>???
i hope to hear soon

posted on 02 May 2011, 08:19

1. loli (unregistered)

i have the same problem , plz can anyone answer ??

posted on 19 May 2011, 20:36

2. prithvi p (unregistered)

I have the same phone.....
1)go to settings in the menu
2)choose "wireless and networks"
3)choose the last option "mobile networks"
there would be an option "use 2g networks only" deactivate that

posted on 14 Oct 2011, 12:06

3. loli (unregistered)

Very very thanks.....

Want to comment? Please login or register.

Latest stories