x PhoneArena is looking for new authors! To view all available positions, click here.
  • Options
    Close




Samsung Galaxy S4 won't work with the older version of Samsung TecTile

0. phoneArena 28 Apr 2013, 20:09 posted on

With the Samsung Galaxy S4 now available in the U.S. from AT&T and Sprint, now would be a good time to tell you that the new Android flagship uses a new NFC chipset which does not support the older version of Samsung's TecTile which means that if you are using the NFC based stickers, you will have to switch to TecTile 2...

This is a discussion for a news. To read the whole news, click here

posted on 28 Apr 2013, 21:03 1

1. HDShatter (Posts: 1021; Member since: 17 Jan 2013)


Atleast the NFC chip in the S4 from Broadcomm is supposed to be a lot better than the s3.

posted on 29 Apr 2013, 00:24

2. Droid_X_Doug (Posts: 5536; Member since: 22 Dec 2010)


Nothing like planned obsolescence.... Hahaha!!!!

posted on 29 Apr 2013, 04:58 1

3. Reverence (Posts: 224; Member since: 16 Jul 2012)


oh so people used these tags..

Want to comment? Please login or register.

Latest stories